Importing EMAC OE SDK QT Projects with Eclipse

From EMAC Wiki
Jump to: navigation, search
TODO: {{#todo:SEOKWREV;(12.31.13-18:15->MG+);(1.2.14-17:25->MG+);(1.3.14-16:30->MG+);(01.03.14-17:05->MD+);(01.03.14-18:15->KY+);(03.04.14-16:45->BS-);(03.25.14-15:35->BS+)|Michael Gloff|oe 4,mg,ky,md,bs,SEOKWREV}}

Qt C++ projects can be built and run with Eclipse through the pre-installed Qt plugin provided with Eclipse from EMAC. Note that the project will only run on EMAC products that contain the appropriate Qt libraries.

EMAC SDK with Qt Example: Compile and Run the textedit Project

Importing the Project

This procedure provides an overview of how to compile and run Qt C++ applications in Eclipse.

  1. Start Eclipse and select a workspace such as /home/developer/workspace.

  2. Click Window → Open Perspective → Other... To bring up a dialog window with a list of Perspectives to choose from.

  3. Choose Qt C++ and click Ok.

  4. Select File → Import...

  5. Expand Qt and select Qt Project

    Eclipse import project step1.png


  6. Click Next >, then click Browse...

  7. Navigate to the projects/qt_demos/textedit directory underneath the install location of the EMAC OE SDK.

  8. Highlight textedit.pro then click OK.

  9. Click Finish.

    Eclipse import project step2.png


Building the Project

The Project Explorer should now show the textedit project.

Eclipse textedit project selected.png


The arrowhead to the left of textedit indicates that the textedit project is open.

  1. Click on the arrowhead to see the files in the project.

  2. Double click on the textedit.cpp file to open it. The arrow next to textedit.cpp can be expanded to see a list of classes and functions available within this source file.

  3. To build the project, ensure the project is highlighted in the Project Explorer treeview in the left pane.

  4. Select Project→Run qmake

  5. Now, select Project→Build Project. The project will now build, and your window should appear similar to the screenshot below:

    Eclipse qt build textedit finished.png


If there are any build errors they will be shown in the Console and/or Problems tabs on the bottom.

Upload the Project

  1. Navigate to the textedit project directory from the command prompt.

    developer@ldc:~$ cd /path/to/sdk/projects/qt_demos/textedit
    
  2. Use scp to copy the file to the target machine's tmp directory

    developer@ldc:~$ scp textedit root@TARGET_IP:/tmp
    

Run the Project

Connect remotely to the target machine using SSH and run the program as shown below.

developer@ldc:~$ ssh root@TARGET_IP
...
root@emac-oe:~# chmod u+x /tmp/textedit
root@emac-oe:~# /tmp/textedit -qws
  • chmod u+x sets the root user's permissions to allow execution of the binary.
  • /tmp/textedit -qws runs the program. Note that the -qws argument is required to run Qt Embedded based applications.

Navigation menu